Map Collector - Help

Back to the main help page

Supported browsers

Map Collector supports the following browsers:

In addition, if you're using iOS, you must be using iOS 12 or later.

Map Collector may work on other browsers too, but these are the browsers that it's been tested on and that it's guaranteed to work on.

Free Web Hosting